#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*"
Local $sString = "KM1208_sta1_cast3.csv" & @CRLF & _
"KM1208_sta1_cast6a.csv" & @CRLF & _
"KM1208_sta1_cast6b.csv" & @CRLF & _
"KM1208_sta2_cast7.csv" & @CRLF & _
"KM1208_sta2_cast6.csv" & @CRLF & _
"HS1301_sta1_cast2.csv" & @CRLF & _
"HS1301_sta2_cast5.csv" & @CRLF & _
"HS1301_sta3_cast8.csv" & @CRLF & _
"HS1301_sta3_cast9.csv"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)