using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*";
string substitution = @"";
string input = @"KM1208_sta1_cast3.csv
KM1208_sta1_cast6a.csv
KM1208_sta1_cast6b.csv
KM1208_sta2_cast7.csv
KM1208_sta2_cast6.csv
HS1301_sta1_cast2.csv
HS1301_sta2_cast5.csv
HS1301_sta3_cast8.csv
HS1301_sta3_cast9.csv";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}