const regex = /\.\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\w+$', 'gm')
const str = `KM1208_sta1_cast3.csv
KM1208_sta1_cast6a.csv
KM1208_sta1_cast6b.csv
KM1208_sta2_cast7.csv
KM1208_sta2_cast6.csv
HS1301_sta1_cast2.csv
HS1301_sta2_cast5.csv
HS1301_sta3_cast8.csv
HS1301_sta3_cast9.csv`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);