# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((https?):\/\/)?([a-zA-Z0-9_][-_a-zA-Z0-9]{0,62}\.)+([a-zA-Z0-9]{1,20})$"
test_str = ("xor\n"
"xor.com\n"
"ww2.xor.co\n"
"www.xor.com\n"
"val-id.com\n"
"-invalid.com\n"
"http://xor.com\n"
"https://xour.cu\n"
"www.http://r.com\n"
"https://ww2.xour.cu\n"
"s2._domainkey.lixtil.com.au\n"
"3426127.group27-.hsbspot.co\n"
"hs2._domainkey.lixtil.com.au\n"
"3426127.grou p27-.hu3spot.co\n"
"little_com_au.xor.tinzy.330.net\n"
"3426127.group27.sites.hubseot.net\n"
"littil-com-au.hs01a.dkim.hubspoteeail.net\n"
"sg2.v8143875.c308460036.e.marketingfutomation.services")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.