# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\+\w+\h?)|./$1/gm;t' <<< "+Z XA( 0,1,6,22,26,33,34,35,36,25,24) +DD +I +M >x1 >bdz +A"