using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\d{1}(?:.\d{3}.)\d{3}-\d{4}";
string input = @"+7(333)333-4444";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}