#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\R+(?=\[\d{2}-\d{2}-\d{4} \d{2}:\d{2}:\d{2}])"
Local $sString = "[30-05-2013 15:45:54] A A" & @CRLF & _
"[26-06-2013 14:44:44] B A" & @CRLF & _
"[26-06-2013 14:44:44] C A" & @CRLF & _
"[26-06-2013 14:43:16] Some lines are so large, they take multiple lines, so explode('\n') won't work because" & @CRLF & _
"I need the complete message" & @CRLF & _
"[26-06-2013 14:44:44] E A" & @CRLF & _
"[26-06-2013 14:44:44] F A" & @CRLF & _
"[26-06-2013 14:44:44] G A"
Local $sSubst = "\n--------------\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)