const regex = /\R+(?=\[\d{2}-\d{2}-\d{4} \d{2}:\d{2}:\d{2}])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\R+(?=\\[\\d{2}-\\d{2}-\\d{4} \\d{2}:\\d{2}:\\d{2}])', 'g')
const str = `[30-05-2013 15:45:54] A A
[26-06-2013 14:44:44] B A
[26-06-2013 14:44:44] C A
[26-06-2013 14:43:16] Some lines are so large, they take multiple lines, so explode('\\n') won't work because
I need the complete message
[26-06-2013 14:44:44] E A
[26-06-2013 14:44:44] F A
[26-06-2013 14:44:44] G A`;
const subst = `\n--------------\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);