using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!SyCs-)[A-Za-z\h\d-]+$";
string input = @"SyCs-b
SyCs-ab
SyCs-ab1
SyCs-abZ
SyCs- abZ
SyCs ab1
TyCs-a
SyCr-a
ab
sab
Csab
yCsab
SyCsab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}