$re = '/^(?!SyCs-)[A-Za-z\h\d-]+$/m';
$str = 'SyCs-b
SyCs-ab
SyCs-ab1
SyCs-abZ
SyCs- abZ
SyCs ab1
TyCs-a
SyCr-a
ab
sab
Csab
yCsab
SyCsab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);