package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(SKU\d{4})\h(.+)\h(.+)`)
var str = `SKU1234 Widget 1 $12.95`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}