import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\S)-ignore\\b|\\bignore-(?=\\S)";
final String string = "hello-world\n"
+ "ignore-good-morning-ignore\n"
+ "good-night-ignore\n"
+ "test1-ignore-test2\n"
+ "test-ignore\n"
+ "ignore-test\n"
+ "ignore-test1-ignore-ignore-test2-ignore";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}