$re = '/(?<=\S)-ignore\b|\bignore-(?=\S)/m';
$str = 'hello-world
ignore-good-morning-ignore
good-night-ignore
test1-ignore-test2
test-ignore
ignore-test
ignore-test1-ignore-ignore-test2-ignore';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;