package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<item>(?<tag_begin>[*|!|_])(?<content>\w+)(?<tag_end>\k<tag_begin>))`)
var str = `hello *asdf* *how* _are_ you !doing! today`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}