re = /(?<item>(?<tag_begin>[*|!|_])(?<content>\w+)(?<tag_end>\k<tag_begin>))/m
str = 'hello *asdf* *how* _are_ you !doing! today'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end