package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:ha.*a|a.*ha).*`)
var str = `aha
harpa
hala
haa
abha
bhab
babh
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}