$re = '/^.*?(?:ha.*a|a.*ha).*/m';
$str = 'aha
harpa
hala
haa
abha
bhab
babh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);