package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([012][0-9])|(3[01]))-([0][1-9]|1[012])-\d\d\d\d [012]{0,1}[0-9]:[0-6][0-9]:[0-6][0-9]$`)
var str = `31-12-2999 12:34:25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}