re = /^(([012][0-9])|(3[01]))-([0][1-9]|1[012])-\d\d\d\d [012]{0,1}[0-9]:[0-6][0-9]:[0-6][0-9]$/m
str = '31-12-2999 12:34:25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end