use strict;
my $str = '1- Deneme
2- Deneme
100- Deneme
35- Deneme
61- ddDSDs
99-testing';
my $regex = qr/\d+- ?(\w+)(\n)?/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";