$re = '/\d+- ?(\w+)(\n)?/m';
$str = '1- Deneme
2- Deneme
100- Deneme
35- Deneme
61- ddDSDs
99-testing';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;