#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[\[).*?(?=\]\])"
Local $sString = "[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]" & @CRLF & _
"[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]" & @CRLF & _
"[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")