$re = '/(?<=\[\[).*?(?=\]\])/m';
$str = '[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]
[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]
[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);