import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*) is eating a ((?:(?!\\b(?:by|at)\\b).)*?)(?: ?\\bby ((?:(?!\\bat\\b).)*?))?(?: ?\\bat (.*))?$";
final String string = "Rafael C. is eating a Burger by McDonalds at Beach\n"
+ "David K. is eating a Burger by McDonalds\n"
+ "John G. is eating a by at House";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}