package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+)(?:\s+\S+){4}\s*$`)
var str = `field1 field2 500 x yz a b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}