$re = '/(\S+)(?:\s+\S+){4}\s*$/';
$str = 'field1 field2 500 x yz a b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);