#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)10\.(?:[0-9]|[0-1][0-9]?|20)\.0\.(?:25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[2-9][0-9]|1[1-9]|[1-9])"
Local $sString = "10.0.0.1" & @CRLF & _
"10.19.0.13" & @CRLF & _
"10.22.0.13" & @CRLF & _
"10.20.0.2" & @CRLF & _
"10.0.0.6" & @CRLF & _
"10.24.0.1" & @CRLF & _
"10.19.0.233" & @CRLF & _
"10.18.0.13" & @CRLF & _
"10.17.0.12" & @CRLF & _
"10.0.0.12" & @CRLF & _
"10.0.0.211" & @CRLF & _
"10.3.0.123" & @CRLF & _
"10.4.0.121" & @CRLF & _
"10.5.0.200" & @CRLF & _
"10.5.0.201" & @CRLF & _
"10.5.0.1" & @CRLF & _
"10.4.0.0" & @CRLF & _
"10.4.0.254" & @CRLF & _
"10.0.0.12" & @CRLF & _
"10.9.0.134" & @CRLF & _
"10.10.0.112" & @CRLF & _
"10.20.0.254" & @CRLF & _
"10.20.0.1" & @CRLF & _
"10.20.0.9" & @CRLF & _
"10.19.0.19" & @CRLF & _
"10.18.0.18" & @CRLF & _
"10.13.0.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")