import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "10\\.(?:[0-9]|[0-1][0-9]?|20)\\.0\\.(?:25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[2-9][0-9]|1[1-9]|[1-9])";
final String string = "10.0.0.1\n"
+ "10.19.0.13\n"
+ "10.22.0.13\n"
+ "10.20.0.2\n"
+ "10.0.0.6\n"
+ "10.24.0.1\n"
+ "10.19.0.233\n"
+ "10.18.0.13\n"
+ "10.17.0.12\n"
+ "10.0.0.12\n"
+ "10.0.0.211\n"
+ "10.3.0.123\n"
+ "10.4.0.121\n"
+ "10.5.0.200\n"
+ "10.5.0.201\n"
+ "10.5.0.1\n"
+ "10.4.0.0\n"
+ "10.4.0.254\n"
+ "10.0.0.12\n"
+ "10.9.0.134\n"
+ "10.10.0.112\n"
+ "10.20.0.254\n"
+ "10.20.0.1\n"
+ "10.20.0.9\n"
+ "10.19.0.19\n"
+ "10.18.0.18\n"
+ "10.13.0.1\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}