$re = '/<li +class="bg-item item-.*" >(.|\n|\r\n)*?<\/li>/m';
$str = '<li class="bg-item item-G38p9" >
<div>mehdi</div>
</li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);