re = /<li +class="bg-item item-.*" >(.|\n|\r\n)*?<\/li>/m
str = '<li class="bg-item item-G38p9" >
<div>mehdi</div>
</li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end