#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*<td\s*>([^<\r\n]+)<\/td\s*>.*<td\s*>([^<\r\n]+)<\/td\s*>"
Local $sString = "<tr >" & @CRLF & _
"" & @CRLF & _
" <th style="text-align:right; background-color:white; color:black" scope="col">Rank</th>" & @CRLF & _
"" & @CRLF & _
" <th style="text-align:right; background-color:white; color:black" scope="col" abbr="male name">Name</th>" & @CRLF & _
"" & @CRLF & _
" <th style="text-align:right; background-color:white; color:black" scope="col" abbr="male number">Number</th>" & @CRLF & _
"" & @CRLF & _
" <th style="text-align:right; background-color:white; color:black" scope="col" abbr="female name">Name</th>" & @CRLF & _
"" & @CRLF & _
" <th style="text-align:right; background-color:white; color:black" abbr="female number">Number</th>" & @CRLF & _
"" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" </thead>" & @CRLF & _
"" & @CRLF & _
" <tbody>" & @CRLF & _
"" & @CRLF & _
"<tr ><td>1</td>" & @CRLF & _
"" & @CRLF & _
" <td >Jacob</td> <td>273,844</td> <td >Emily</td> <td>223,690</td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr ><td>2</td>" & @CRLF & _
"" & @CRLF & _
" <td >Michael</td> <td>250,554</td> <td >Madison</td> <td>193,152</td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr ><td>3</td>" & @CRLF & _
"" & @CRLF & _
" <td >Joshua</td> <td>231,926</td> <td >Emma</td> <td>181,257</td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr ><td>4</td>" & @CRLF & _
"" & @CRLF & _
" <td >Matthew</td> <td>221,513</td> <td >Olivia</td> <td>156,000</td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr ><td>5</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")