use strict;
my $str = '<tr >
<th style="text-align:right; background-color:white; color:black" scope="col">Rank</th>
<th style="text-align:right; background-color:white; color:black" scope="col" abbr="male name">Name</th>
<th style="text-align:right; background-color:white; color:black" scope="col" abbr="male number">Number</th>
<th style="text-align:right; background-color:white; color:black" scope="col" abbr="female name">Name</th>
<th style="text-align:right; background-color:white; color:black" abbr="female number">Number</th>
</tr>
</thead>
<tbody>
<tr ><td>1</td>
<td >Jacob</td> <td>273,844</td> <td >Emily</td> <td>223,690</td></tr>
<tr ><td>2</td>
<td >Michael</td> <td>250,554</td> <td >Madison</td> <td>193,152</td></tr>
<tr ><td>3</td>
<td >Joshua</td> <td>231,926</td> <td >Emma</td> <td>181,257</td></tr>
<tr ><td>4</td>
<td >Matthew</td> <td>221,513</td> <td >Olivia</td> <td>156,000</td></tr>
<tr ><td>5</td>';
my $regex = qr/^\h*<td\s*>([^<\r\n]+)<\/td\s*>.*<td\s*>([^<\r\n]+)<\/td\s*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}