#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0\+\(][\d\-\.\+ \)\(\/]{10,22}"
Local $sString = "(06442) 3933023" & @CRLF & _
"(02852) 5996-0" & @CRLF & _
"(042) 1818 87 9919" & @CRLF & _
"06442 / 3893023" & @CRLF & _
"06442 / 38 93 02 3" & @CRLF & _
"06442/3839023" & @CRLF & _
"042/ 88 17 890 0" & @CRLF & _
"+49 221 549144 – 79" & @CRLF & _
"+49 221 - 542194 79" & @CRLF & _
"+49 (221) - 542944 79" & @CRLF & _
"0 52 22 - 9 50 93 10" & @CRLF & _
"+49(0)121-79536 - 77" & @CRLF & _
"+49(0)2221-39938-113" & @CRLF & _
"+49 (0) 1739 906-44" & @CRLF & _
"+49 (173) 1799 806-44" & @CRLF & _
"0173173990644" & @CRLF & _
"0214154914479" & @CRLF & _
"02141 54 91 44 79" & @CRLF & _
"01517953677" & @CRLF & _
"+491517953677" & @CRLF & _
"015777953677" & @CRLF & _
"02162 - 54 91 44 79" & @CRLF & _
"(02162) 54 91 44 79" & @CRLF & _
"+49 (0) 69 707 9839-536" & @CRLF & _
"+4915254509290" & @CRLF & _
"+49 (0) 211 913583-583" & @CRLF & _
"0211 922-2404" & @CRLF & _
"(02131) 29571-16" & @CRLF & _
"07161/302-279" & @CRLF & _
"0211 477-1539" & @CRLF & _
"819508968230" & @CRLF & _
"1639576326258" & @CRLF & _
"1639576328598" & @CRLF & _
"06185754740463387" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")