re = /[0\+\(][\d\-\.\+ \)\(\/]{10,22}/m
str = '(06442) 3933023
(02852) 5996-0
(042) 1818 87 9919
06442 / 3893023
06442 / 38 93 02 3
06442/3839023
042/ 88 17 890 0
+49 221 549144 – 79
+49 221 - 542194 79
+49 (221) - 542944 79
0 52 22 - 9 50 93 10
+49(0)121-79536 - 77
+49(0)2221-39938-113
+49 (0) 1739 906-44
+49 (173) 1799 806-44
0173173990644
0214154914479
02141 54 91 44 79
01517953677
+491517953677
015777953677
02162 - 54 91 44 79
(02162) 54 91 44 79
+49 (0) 69 707 9839-536
+4915254509290
+49 (0) 211 913583-583
0211 922-2404
(02131) 29571-16
07161/302-279
0211 477-1539
819508968230
1639576326258
1639576328598
06185754740463387
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end