use strict;
my $str = 'FPCN54 CWNT 080810^r^r EXTENDED FORE
ASUS42 KMHX 080425^r^r RWRMHX^r^r WEAT
RXUS30 KWNO 081300^r^r XOBUS ^r^r <?xm';
my $regex = qr/([A-Z0-9]{6})\s([A-Z]{4})\s([0-9]{6})([\^|r])+\s([A-Z]+)([\^|r\s]+)(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}