$re = '/([A-Z0-9]{6})\s([A-Z]{4})\s([0-9]{6})([\^|r])+\s([A-Z]+)([\^|r\s]+)(.+)/m';
$str = 'FPCN54 CWNT 080810^r^r EXTENDED FORE
ASUS42 KMHX 080425^r^r RWRMHX^r^r WEAT
RXUS30 KWNO 081300^r^r XOBUS ^r^r <?xm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);