$re = '/(?<!<number start>|\d)\d+(?:\.\d+)?(?!\d|<number end>)/m';
$str = 'first number <number start>123.45<number end>
and second number 678.90.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);