re = /(?<!<number start>|\d)\d+(?:\.\d+)?(?!\d|<number end>)/m
str = 'first number <number start>123.45<number end>
and second number 678.90.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end