package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(?<tag>\w+)[^>]*>[^<]+<\/\k<tag>>`)
var str = `<span style="color: red">hey</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}