re = /<(?<tag>\w+)[^>]*>[^<]+<\/\k<tag>>/m
str = '<span style="color: red">hey</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end