using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(?<=Feb )([1-2][0-9])|([1-2][0-9]|3[0-1]))";
string input = @"Dates worked: Feb 28, Feb 29, Feb 30, Mar 30, Mar 31";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}