$re = '/(?(?<=Feb )([1-2][0-9])|([1-2][0-9]|3[0-1]))/m';
$str = 'Dates worked: Feb 28, Feb 29, Feb 30, Mar 30, Mar 31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);