package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(hey(?R)?oh)`)
var str = `heyoh heyyoh heyheyohoh hey oh heyhey heyheyheyohoh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}