$re = '/(hey(?R)?oh)/m';
$str = 'heyoh heyyoh heyheyohoh hey oh heyhey heyheyheyohoh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);