package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|,)\s*(?:\"([^",]*)\"|([^", ]*))`)
var str = `a, "b", "c d",e,f, "g h", dfgi,, k, "", l`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}