re = /(?:^|,)\s*(?:\"([^",]*)\"|([^", ]*))/m
str = 'a, "b", "c d",e,f, "g h", dfgi,, k, "", l'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end