package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\[ntr]`)
var str = `\`\r\`, \`\t\`, and \`\n\` are all regex escape sequences.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}