package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).`)
var str = `I'm sorry, Dave. I'm afraid I can't do that.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}