$re = '/\\\\./m';
$str = 'Hi Walmart is my grandson there his name is "\\n \\r \\t".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);