re = /[b-df-hj-np-tv-z]/m
str = 'The walls in the mall are totally, totally tall.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end